익스플로어8 브라우저 이미지 뿌옇게 보이는 문제 있다... 블록

제가 어제 오후 9시 50분 경에 제로보드 4.1pl8 버전 이미지박스에 "국민신문고_공개민원1.png" 란 이미지를 하나 올린 적이 있었는데요 그 이미지가 켑쳐 이미지라 깨끗하게 보이는데 오늘 다시 익스플로어8(IE8) 브라우저로 다시 페이지를 로드해 보니 폰트나 해상도 자체가 약간 번지듯 뿌옇게 보이는 문제가 있네요.

오후 2시 6분 현재 아래 두 개 페이지를 함 비교해 보세요. 희안하네요. 버그인지 삑사리인지는 모르겠지만 뭔가 이상합니다.

http://www.blrun.net/bbs/zboard.php?id=basket1&page=1&sn1=&divpage=1&sn=off&ss=on&sc=on&sm=on&select_arrange=headnum&desc=asc&no=169

http://run.iptime.org:84/bbs/zboard.php?id=basket1&page=1&sn1=&divpage=1&sn=off&ss=on&sc=on&sm=on&select_arrange=headnum&desc=asc&no=163

근데 이 이미지를 호스팅 서버에서 다운로드해 이미지 뷰어로 보면 두번째 이미지 같이 깨끗하게 보인다는 겁니다. 문제의 페이지가 첫번째 페이지구요. 지금 재현되고 있는데 이상하지 않습니까?

덧글

  • 희망의빛™ 2013/11/20 14:13 # 답글

    지금 두번째 링크가 정상적으로 깨끗하게 보이질 않고 있습니다. 제 브라우저에선 지금 제대로 깨끗하게 보이는데 이상하게 링크를 거니까 첫번째 페이지와 같이 흐릿하게 보이네요. 이건 또 무슨 문제죠? 참... 알 수가 없네.
  • 희망의빛™ 2013/11/20 14:19 # 답글

    브라우저에 로드된 이미지를 다른 이름으로 저장해서 이미지 뷰어로 함 보세요. 이미지 뷰어에 나타난 것처럼 깨끗하게 보여야 정상인데 이상합니다. 이건 또 무슨 문제일까요?
  • Hide_D 2013/11/20 23:45 # 답글

    아..............하
    일단 원인은 이미지 리사이즈를 위해 삽입된 코드인
    zb_img_check()
    함수가
    document.zb_get_table_width.width
    의 크기를 1034로 잡으면서 가로가 906인 이미지를 900으로 바꿔버리면서 생기는 문제네요.
  • Hide_D 2013/11/21 00:02 # 답글

    스킨 코드에서
    <img src=images/t.gif border=0 width=98% height=1 name=zb_get_table_width>
    라고 나온 부분이 있으면 98%에서 99%로 바꿔보세요.

    혹은 아래 zb_img_check에 접근가능하시면
    -134를 -128로 바꿔보세요(이쪽이 더 나음)
  • Hide_D 2013/11/21 00:01 # 답글

    원래 block 타입의 경우엔 따로 지정하지 않는 경우에는 width가 100%이 되어야 하는데,
    IE8에서는 안에 있는 객체 크기를 계산해서 가능한 최소치를 일일히 계산하는 것 같습니다.

    그래서 패딩을 다 치고 보니 6만큼 차이가 났나 봅니다.
    ZB4 코드를 보니 비정상으로 보이는 IE8의 코드가 원래 의도한 것일지도 모르겠네요
  • 희망의빛™ 2013/11/21 08:08 #

    Hide_D님, 상세한 덧글 감사드립니다.

    말씀하신 내용이 무슨 이야기인지 대충은 알것 같습니다만 제가 이미지를 처음에 올렸을 땐 이미지 사이즈 폭이 zb_img_check() 함수의 zb_main_table_width 보다 작기 때문에 정상적으로 폭이 줄어들지 않고 깨끗하게 보였는데 시간이 지나니까 첫번째 링크도 그렇고 두번째 링크도 그렇고 말씀하신대로 쫄아든 이미지처럼 뿌옇게 보인다는 겁니다. 그 부분이 이해가 안갑니다. 그리고 이미지를 클릭하면 확대된 이미지가 마우스 움직임에 따라 자유자재로 움직이게끔 자바스크립트로 동작하게 돼 있는데 이미지를 클릭해 보시면 알겠지만 이미지가 깨끗하게 보이지 않고 쫄아든 그림처럼 뿌옇게 보입니다.

    이건 왜 그런 건가요? ㅡ_ㅡ;
  • 희망의빛™ 2013/11/21 14:45 #

    일단 다른 건 건드리지 않고 zb_img_check() 함수의 -134를 -142로 바꾸고 익스플로어 브라우저의 텍스트 크기를 확인한 후 보통 크기로 바꾸었더니 해결은 되었네요. 숫자를 바꿔서 그런지 아니면 텍스트 크기 때문인지는 확인이 안되었지만 어쨌든 지금은 브라우저에서 또렷하게 보이는군요.
  • 희망의빛™ 2015/09/09 06:52 # 답글

    제가 익스플로어8 우상단 "페이지" 탭의 텍스트 크기를 "보통" 100%로(마우스로 치면 Ctrl+휠 로 조정) 바꾸었더니 해결이 되었습니다. 아마도 텍스트 크기가 미세하게 변화된 것 때문이 아닌가 싶은데 이 글을 보시는 유저분들도 함 테스트해 보시기 바랍니다. ㅡ_ㅡ;

    http://www.blrun.net/bbs/zboard.php?id=basket1&page=1&sn1=&divpage=1&sn=off&ss=on&sc=on&sm=on&select_arrange=headnum&desc=asc&no=169

    http://run.iptime.org:84/bbs/zboard.php?id=basket1&page=1&sn1=&divpage=1&sn=off&ss=on&sc=on&sm=on&select_arrange=headnum&desc=asc&no=163

    http://run.iptime.org:81/bbs/zboard.php?id=basket1&page=1&sn1=&divpage=1&sn=off&ss=on&sc=on&sm=on&select_arrange=headnum&desc=asc&no=163

    세 URL에서 모두 테스트해 보시기 바랍니다.
댓글 입력 영역
* 비로그인 덧글의 IP 전체보기를 설정한 이글루입니다.


웹로그 검색