이 2개 페이지에서 왜 첫번째 페이지에선 노란 바탕이 보이지 않는지 아시는 분은 제가 이뻐해 줄께요. ㅋㅋ 블록

아래 소스는 image 경로만 빼고 완전히 2개가 똑같은 소스입니다. 왜 첫번째 소스에서 노란 바탕이 보이지 않고 두번째 소스에선 노란바탕이 보이는지 이걸 아시는 분은 제가 웹개발자 칭호를 드릴께요. ㅎㅎ 어제 이 문제 찾느라 개고생하고 피곤해서 낮잠을 잤는데 오늘 새벽 원인을 찾았네요.

http://www.blrun.net/bbs/test4.html
http://www.blrun.net/bbs/test4_1.html

덧글

  • 희망의빛™ 2015/08/31 07:44 # 답글

    이론... 정답을 벌써 알려드려야 할 것 같습니다. 제가 관련 소스를 수정한 다음 포스트를 올렸네요. 94행 쯤에 style.css 파일 보이시죠? 그 스타일시트를 추적해 보면 2.0과 3.0 이 약간 다른데 3.0 소스 안에서 body 태그 스타일의 백그라운드 색상이 흰색으로 돼 있어서 test4.html 이 bgcolor를 노란색으로 했음에도 불구하고 흰색으로 보였던 겁니다. ㅎㅎ 알고 보면 쉬운 문제인데 한참을 헤매었네요. ㅋㅋ
  • zxc 2015/08/31 11:17 # 삭제 답글

    전 둘다 노란색으로 나오는데요?
  • 지나가다 2015/08/31 11:21 # 삭제 답글

    말씀해주신대로 그런 부분은 무색 처리를 하거나 아예 공란을 해버리시는게 좋을 듯 하네요.

    그나저나 슬슬 이글루스에서 이사 가시나보네요 이사 잘 되시길
  • ㅁㄴㅇㄹ 2015/08/31 12:00 # 삭제 답글

    크롬이던 IE11이던 둘다 노란색 뜨는데 무슨 차이가 있다고 합니까?

    그리고 이게 뭐 대단한거라고 웹개발자 운운입니까? 정작 본인은 개발자가 아니지 않습니까?
  • ㅁㄴㅇㄹ 2015/08/31 12:04 # 삭제

    그리고 노란색 원색 그대로 쓰니까 눈 아픕니다. 모니터 핑계 대지 마세요. 다른 PC 모니터에서도 눈아파요. 노트북, 학교 PC에서도 눈아픈데 모니터탓하실 생각은 아니죠?
  • 희망의빛™ 2015/09/01 20:03 # 답글

    못참겠네요. 아래는 고객센터에 보낸 문의글입니다.
    =============================================================

    제목: 이글루스가 로딩이 지연되고 트위터 버튼이 사용불가합니다

    아래 내용을 반드시 기재해주세요.

    - 닉네임 : 희망의빛™
    - 블로그 URL : http://blrun.egloos.com/
    (*기억나지 않으신다면 비워두셔도 되지만, 문의 처리 시 지연 될 수 있습니다.)
    - 문의내용 : 첨부파일을 보시면 아시겠지만 이글루스가 로딩이 지연되면서 트위터 버튼이 사용불가합니다. 어제부터 계속 그러던데 왜 그런지와 빠른 정상화 부탁드립니다.
  • 희망의빛™ 2015/08/31 21:34 #

    아래와 같은 답변이 왔네요. ㅡ_ㅡ 요 며칠 동안 계속 트위터 버튼이 안됐는데 증상이 없었답니다.
    ============================================================================================

    문의에 대한 답변

    안녕하세요, 이글루스 고객센터 입니다.

    고객센터로 보내주신 내용을 확인하였으나 안타깝게도 해당 현상이 재현되지 않으며,

    트위터 버튼이 아래와 같이 정상적으로 동작하는 것을 확인할 수 있었는데요.

    해당 현상은 간혹 사용하시는 인터넷 환경 또는 웹 브라우저의

    캐시 파일로 인해 트위터 버튼 로딩이 일시적으로 지연될 가능성이 있습니다.

    이 때는 번거로우시더라도 새로고침(Ctrl + F5)을 여러 번 해보시거나

    인터넷 임시 파일을 삭제하신 후 다시 시도해 보시기 바랍니다.

    감사합니다.

    오늘도 좋은 하루 되세요
  • 희망의빛™ 2015/08/31 21:54 # 답글

    이곳 이글루스 개발자는 악마네요. 방금 이글루스 소스를 고쳐놨습니다. 도저히 못참겠네요. 이곳에 남아있다가는 제가 병나게 생겼습니다. 완전 겐세이가 도를 지나치는군요. 헐~
  • 이운재 2015/08/31 21:58 # 삭제

    아 그러면 좀 꺼지던가. 말로만 그러지 말고.
  • ㅁㄴㅇㄹ 2015/08/31 22:55 # 삭제

    그거야 님 컴퓨터가 구형이니까요. 겐세이 겐세이 운운하지 말고요. 그럴거면 이글루스 처들어가서 난장판이라도 만들려고요?
  • 탐미주의 2015/09/01 00:12 # 답글

    파이어폭스 씁니다만 저도 둘 다 노란색입니다. 희망의빛님 노란색 참 좋아하시네요.
  • 무한 2015/09/01 06:06 # 답글

    자문자답하고 웹개발자 타이틀 다시게요? -_-
  • ㅇㅇㅇ 2015/09/03 12:58 # 삭제 답글

    고치긴 뭘 고쳐 진짜 병이다 병...
  • 희망의빛™ 2015/09/03 19:07 # 답글

    zxc, ㅁㄴㅇㄹ, 탐미주의// 제가 관련 소스(style.css)를 수정하고 test4.html 과 test4_1.html 을 올려서 문제가 해결 된 채로 보이는 겁니다. 문제가 해결되기 전의 소스를 올려드렸어야 했는데 관련 소스를 수정하고 테스트 페이지를 올려서 수정된 style.css 가 반영 돼 둘 다 노란색으로 보였던 겁니다. 수정증보판 1.2.4.XXX 버전 말고 그 이전 배포판을 다운받아 보시면 2.0 과 3.0 style.css 의 차이점을 확인할 수 있습니다. 거기서 body 태그의 백그라운드 색상이 흰색인 것을 확인할 수 있답니다. 이게 제로보드4 관리자 메뉴 게시판 설정화면에서 배경색을 지정할 수 있는데 배경색을 지정하면 테스트 페이지 body 태그를 보시는 바와 같이 bgcolor가 그 배경색으로 지정이 되는데 이전 코드에선 style.css에서 body 태그의 백그라운드 색상을 흰색으로 지정했기 때문에 본문 body 태그의 bgcolor가 무시된 것이죠. ^^;

    ㅇㅇㅇ// 지금 다시한번 그런 현상이 발생하는지 면밀히 테스트하고 있습니다. 며칠동안 계속 딜레이 현상이 생기다가 어제 잠깐 괜찮아지고는 오늘 다시 또 그랬는데 지금 캐쉬를 비우고 나니 다시 현상이 사라졌네요. 일단 소스상의 문제인것 같은데 캐쉬를 비웠으니 지금 이후로 다시한번 그런 현상이 발견되면 제가 증거 자료를 켑쳐해 보여드리겠습니다.
  • 희망의빛™ 2015/09/09 21:16 # 답글

    지금도 계속 크롬에서 이글루스가 로딩이 지연되면서 트위터 버튼이 사용불가로 뜨는데 켑쳐해 올리기가 귀찮아서 못하고 있네요. 다른 분들은 괜찮으신지... 헐~ 이글루스가 이젠 막나가자는 것 아닌지... ㅡ_ㅡ
  • asdf 2015/09/10 13:57 # 삭제

    그건 님 PC의 문제지, 다른 사람은 멀쩡해요. 이글루스가 막 나가서가 아니라 구형 PC에 구형 OS를 쓰니까 그렇다는 겁니다.
    17만원이면 님이 가진 PC보다 월등이 좋은 PC 살수 있는데 10년전 출시된 싱글코어 PC를 17만원에 팔려는 님같은 사람이 이해나 할런지 모르겠습니다만.
  • 총통 R 레이퍼 2015/09/10 16:17 #

    고사양 컴 + 기가인터넷 사용자입니다.
    멀쩡하게 잘만 돌아갑니다. 오류도 하나 없이 말이죠.
  • 희망의빛™ 2015/09/10 19:30 # 답글

    asdf, 총통 R 레이퍼// 다른 사이트들은 다 지연없이 잘 뜬답니다. 이글루스만 계속 그래요. 그럼 크롬의 음모일까요? ㅋㅋ
  • 누군가의친구 2015/09/17 20:06 #

    내 PC는 물론 근처 도서관PC도 멀쩡한데 뭔 크롬의 음모 운운이야? 사고 수준이 그모양이니 매번 욕먹지.
댓글 입력 영역
* 비로그인 덧글의 IP 전체보기를 설정한 이글루입니다.


웹로그 검색